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The Processor: Datapath & Control

2 We're ready to look at an implementation of the MIPS

2 Simplified to contain only:
® memory-reference instructions: 1w, sw

® arithmetic-logical instructions: add, addu, sub, subu,
and, or, xor, nor, slt, sltu

@ arithmetic-logical immediate instructions: addi, addiu,
andi, ori, xori, slti, sltiu

@ control flow instructions: beq, 1

2 Generic implementation:

® use the program counter (PC) to supply
the instruction address and fetch the
instruction from memory
(and update the PC)

® decode the instruction (and read registers)
® execute the instruction
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Abstract Implementation View

2 Two types of functional units:
® elements that operate on data values (combinational)
® elements that contain state (sequential)

Instruction »Write Data »Address
. Read R
Memory Register Dat >
> Reg Addr ata Data
PC—>|Address Instructior File YAL Memory ReadData
»Reg Addr
Read »\Write Data
Data
»Reg Addr

2 Single cycle operation

2 Split memory (Harvard) model - one memory for
instructions and one for data

CENG3420 L06.3 Spring 2017



Fetching Instructions

2 Fetching instructions involves
@ reading the instruction from the Instruction Memory

® updating the PC value to be the address of the next
(sequential) instruction

clock l l ﬁ
4 —>
Fetch
= PC+ Instruction
Memory
Exec Decode __[pcHRead Instructior—

" |Address

e PC is updated every clock cycle, so it does not need an
explicit write control signal

@ Instruction Memory is read every clock cycle, so it
doesn’t need an explicit read control signal
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Decoding Instructions

2 Decoding instructions involves

® sending the fetched instruction’s opcode and function
field bits to the control unit

Fetch
PC = PC+4
e &
»Read Addr 1
RegisterDZfaa? I
a R
Instruction »Read Adf1r2
File
\Write Addr Read
. Data 2
Write Data

@ reading two values from the Register File
- Register File addresses are contained in the instruction
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Reading Registers “Jdust in Case”

2 Note that both RegFile read ports are active for all
iInstructions during the Decode cycle using the rs and
rt instruction field addresses

® Since haven't decoded the instruction yet, don’t know what
the instruction is !

® Just in case the instruction uses values from the RegFile
do “work ahead” by reading the two source operands

Which instructions do make use of the RegFile values?
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EX:

2 All instructions (except ) use the ALU after
reading the registers. Please analyze memory-
reference, arithmetic, and control flow
Instructions.
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Executing R Format Operations

J R format operations (add, sub, slt, and, or)
31 25 20 15 10 5 0

R-type: op | rs | rt |rd |shamt| funct

® perform operation (op and funct) on values in rs and rt
@ store the result back into the Register File (into location rd)

RegWrite ALU control
»Read Addr 1 \\
Fetch Registerszaa? >
— »R
PC = PC+4 Instruction »Read Alcifallrz > — overflow
ile — Zero
o ALU
@ Decode »\Write Addr Read R
. Data 2
»\\rite Data

® Note that Register File is not written every cycle (e.g. sw), so
we need an explicit write control signal for the Register File
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Consider the s1t Instruction
2 Remember the R format instruction s1t

slt $St0, S$s0, S$sl1 # 1if $sO < Ssl
# then $St0 =1
# else St0 =0

® Where does the 1 (or 0) come from to store into $t0 in the
Register File at the end of the execute cycle?

RegWrite ALU control
»Read Addr 1 \\

Register Read >

Instruction >Read Addr2 Data — overflow
| File > > zero
YYE ALU
»\Write Addr Read ‘
. Data 2 -

»\Write Data
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Executing Load and Store Operations

2 Load and store operations have to
31 25 20 15 0

I-Type: | op rs rt | address offset

e compute a memory address by adding the base
register (in rs) to the 16-bit signed offset field in the
Instruction

- base register was read from the Register File during
decode

- offset value in the low order 16 bits of the instruction
must be sign extended to create a 32-bit signed value

e store value, read from the Register File during
decode, must be written to the Data Memory

@ load value, read from the Data Memory, must be
stored in the Register File
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Executing Load and Store Operations, con’t

Instruction
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RegWrite

l

Read Addr1

v

ALU control

overflow

. Read
Register
Read Addr2 Data 1

v

v

File

\Write Addr Read

Data 2=
\Write Data

v

v

MemWrite

l

Address

v

Data
Memory Read Data

\Write Data

\ Sign

\16 Exten 32

T

MemRead
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Executing Branch Operations

2 Branch operations have to
31 25 20 15 0

I-Type: | op rs rt | address offset

e compare the operands read from the Register File
during decode (rs and rt values) for equality (zero

ALU output)

® compute the branch target address by adding the
updated PC to the sign extended16-bit signed
offset field in the instruction

- “base register” is the updated PC

- offset value in the low order 16 bits of the instruction
must be sign extended to create a 32-bit signed
value and then shifted left 2 bits to turn it into a word
address
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Executing Branch Operations, con’t
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v

Instruction

Read Addr1

v

Register
Read Addr2

v

File
\Write Addr

\Write Data

Read

Branch
target
address

N >Add

ALU control

zero (tobranch

Data 1

Read

control logic)
>ALU

Data 2

R Sign

\16 Exten 32
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Executing Jump Operations

2 Jump operations have to

J-Type:

jump target address

o replace the lower 28 bits of the PC with the lower 26 bits
of the fetched instruction shifted left by 2 bits
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) ] Jump
address
28
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Spring 2017



Creating a Single Datapath from the Parts

2 Assemble the datapath elements, add control lines
as needed, and design the control path

2 Fetch, decode and execute each instruction in one
clock cycle — single cycle design
® no datapath resource can be used more than once per

instruction, so some must be duplicated (e.g., why we
have a separate Instruction Memory and Data Memory)

o to share datapath elements between two different
instruction classes will need multiplexors at the input of
the shared elements with control lines to do the
selection

2 Cycle time is determined by length of the longest
path
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Fetch, R, and Memory Access Portions

YAd RegWrite ALU control MemWrite
4 ' l ovf l
TZGI'O
. »Read Addr 1
Instruction _ Read »Address
Memory ReglsterD ta 1
»Read Addr2 Pata Data
Read . :
—» PCH— Instruction File > — Memory ReadData
Address S\ /i ALU y
»\\rite Addr Read pan
il Ve Data 2| { Write Data
\ \Write Data -
- ]
_ MemRead
\ Sign
\1 6 Extend 32
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Multiplexor Insertion

YAdd RegWrite ALUSrc ALU control MemWrite MemtoReg
4 ' l ovf l
TZGI'O
. »Read Addr1
Instruction _ Read »Address
Memory ReglsterD ta 1
»Read Addr2 “ata Data
Read : i
—PCH—> Instructior File > — Memory Read Dataj—»
Address >Write Addr (A y
Readh
Data 2 Write Data
s
Write Data >
_ MemRead
\ Sign

\16 Extend 32
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Clock Distribution

System Clock

clock cycle

ALUSrc ALU control

ovf
Tze ro

MemWrite

MemtoReg

Address

>ALU ]

v

Data
Memory Read Data

v

\Write Data

> \ RegWrite
YAdd
4 ——>
Instruction > ReadRAddr 1 Read
Memor egister
y »Read Addr2 Data 1
L, pcH[Read Instruction File il
Address »Write Addr g
ead-j
Data 2
\Write Data
\ Sign

\16 Extend 32

T

MemRead

CENG3420 L06.18

Spring 2017



Adding the Branch Portion

v

»

YAdd
4 > /

Instruction
Memory

Read

RegWrite

l

Read Addr1

v

. Read
Register
Read Addr2 Data 1

> A ddress Instructior

v

File

v

\Write Addr Read

ALUSrc

v

YAdd

v

PCSrc

ALU control MemWrite MemtoReg

ovf
Tzero

l

Address

. Data 2
\Write Data
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v

Data
Memory Read Data

v

\Write Data
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T

MemRead
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Our Simple Control Structure

2 We wait for everything to settle down
® ALU might not produce “right answer” right away

® Memory and RegFile reads are combinational (as are
ALU, adders, muxes, shifter, signextender)

® Use write signals along with the clock edge to determine
when to write to the sequential elements (to the PC, to
the Register File and to the Data Memory)

2 The clock cycle time is determined by the logic
delay through the longest path

We are ignoring some details like register
setup and hold times
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Summary: Adding the Control

0 Selecting the operations to perform (ALU, Register
File and Memory read/write)

2 Controlling the flow of data (multiplexor inputs)

2 Information comes from the 32 bits of the instruction
31 25 20 15 10 5 0

20 Observations  R-type:| op | rs | rt |rd |shamt| funct

e op field always

in bits 31-26 31 25 20 15

e addr of two I-Type: | op rs rt | address offset

registers to be
read are always specified by the
rs and rt fields (bits 25-21 and 20-16)

e base register for lw and sw always in rs (bits 25-21)

® addr. of register to be written is in one of two places —in rt
(bits 20-16) for Iw; in rd (bits 15-11) for R-type instructions

e offset for beq, Iw, and sw always in bits 15-0
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(Almost) Complete Single Cycle Datapath

i—>PC

v

»

v

YAdd
4 > /

Instruction
Memory

v

Address
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Read Instr[31-0]=—

Instr[25:21

Instr[15-0]

0
>Ad 1
—
PCSrc
RegDst RegWrite ALUSrc MemWrite MemtoReg
l OVizaro l
Read Addr 1
A
Register Read Address
Read Addr2 Data 1 Data
] File v >ALU Memory Read Data >
\Write Addr Read
Data 2 ' \Write Data 0
»\\Vrite Data
- ]
. @\ — MemRead
‘16 @ ‘32
Instr[5-0]
ALUOp
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ALU Control

2 ALU's operation based on instruction type and function

code

2 Notice that we are using different encodings than in

the book
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ALU control Function
iInput
0000 and
0001 or
0010 Xor
0011 nor
0110 add
1110 subtract

1111

set on less than
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EX: ALU Control, Con’t

2 Controlling the ALU uses of multiple decoding levels
® main control unit generates the ALUOp bits
® ALU control unit generates ALUcontrol bits

Instrop | funct | ALUOp| action | ALUcontrol
lw XXXXXX 00

SW XXXXXX 00

beq XXXXXX 01

add 100000 10 add 0110
subt 100010 10 subtract 1110
and 100100 10 and 0000
or 100101 10 or 0001
Xor 100110 10 xor 0010
nor 100111 10 nor 0011
slt 101010 10 sit 1111
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ALU Control Truth Table

Our ALU m control input

0 Four, 6-input truth tables
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FS|F4 |F3|F2 | F1|{FO| ALU | ALU M ALU ALU -WU\
Op; OpOWntmbW
X[X|X|X[X[X] 0] 0] /] 141 O
X|X[X|X|x|x| o | 1t |[1\] A ] 1 N
X|x|ofofo|o| 1 | o [[o]|]/" 1 0\
X|X[ojo[1[o| 1 | 0 [] 1 1 0
X|Xjo[1]ofo| 1| o f|lo]lfo | o] o
X|X|0[1|/0[1| 1 | O 0]\ O 0 1
X|x|o[1]{1]{o] 1 ] o [|o]|\o 1 0 /
X|X[o[1][1]1] 1 ] o |lo/|] N | ¢ 1/
xixjrjoftjol 1o [\ | IN 1 |7
Add/subt Mux control
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ALU Control Logic

2 From the truth table can design the ALU Control logic

Instr[3]

Instr[2]

Instr[1]

Instr[0]

ALUOp,

ALUOp,

e

)L

)L

) L
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ALUcontrol;

ALUcontrol,

ALUcontrol,

ALUcontrol,
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(Almost) Complete Datapath with Control Unit

/ \Add
4 —>
—> PCSrc
ALUO Branch
MemRead
Instr[31-2 Control MemioReg
Unit VMemwvrite
ALUSrc
RegWrite
RegDst
A\ 4 O\T/f A\ 4
. Instrf25:21L I ead Addr 1
Instruction Read Address
Memor Register a
y Instr[20:16 |0 .o q Addr2 Data 1 zer Dat
Read l i ata b
—PCH— Instr[31-0}=- 0 File > Memory Read Datal—>»|1
Address Write Addr — Roagbd S ALU y
i str[1l 1 _ Data 2 Write Data 0
\Write Data N
-11] -
|
Instr[15-0] \ G_!m\\
*16 @ '32
Instr[5-0]
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R-t

e Instruction Data/Control Flow

—PC

v

7

Instruction
Memory

_|Read
“|Address

Instr[31-0]

€
SAdd
—’ PCSrc
LU0 Branch Vermrend
emRea
Instr[li1-2 Control MemioReg
| Unit Memvvrite
ALUSrc

RegWrite
RegDs

11 ovf 10
Instr[25:21] R ead Addr 1 T\

- Read Address

Register >
File > Read Data :?
i ALU Memory
| 1 Write Addr Read 5 |
Instr] \Write Dat Data 2 Write Data 0
1] Write Data i
0

Instr[15-0]

6 32
Instr[5-0] 9

CENG3420 L06.28

Spring 2017




Store Word Instruction Data/Control Flow

N [
b K 0
Add >
/ SAdd—» 1
4 —>
—> PCSrc
ALUO Branch
MemRead
Instr[431-2 Control MemioReg
| Unit NMemvvrite
ALUSrc
RegWrite
RegDs
0 ovf 1
A\ 4 T A\ 4
] Instr[25+21 Read Addr 1
Instruction Read JAddress
Memor Register > »A
Read : N
»PCH—> Instr[31-0]-- File > Memory Read Datar—>»|1
Address Write Addr P ALU y
| ol Read 0
Instr[1 Data 2 Write Data 0
1] Write Data
. 10
Instr[15-9] \\ @ \\
16 w 32 ‘)
Instr[5-0] “,
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Load Word Instruction Data/Control Flow

v

7

Instruction
Memory

_|Read

—PC— Address

Instr[31-0]

6 w ‘32
Instr[5-0]

I
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[
KO
SAdd—|1
—’ PCSrc
LU0 Branch
L MemRead
Instr[31-26] Control MemioReg
| Unit NVemvvrite
ALUSrc
RegWrite
RegDs
‘,1 ovf v0
Instr(25:21] Read Addr 1 T\
i Read Address
Register >
Instr[20:16 Read Addr2 Data 1 zer Data [
File > Memory ReadData ?
Write Addr g, ~I\0 ALU y X
—_— ea |
Instr[1 , Data 2 Write Data 0
11 Write Data
) ] A1
Instr{15-0] X @\
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Branch Instruction Data/Control Flow

Add
4 —>
— PCSrc
ALUO B@
S MemRead
Instr[81-26] Control MemioReg
| Unit NMemvvrite
ALUSrc
RegWrite
RegDs
VO O\T/f VO
] Instr[25+21 Read Addr 1
Instruction Read Address
Memory Instri20-16 Register > : A
st Read Addr2 Data1 e Data
Read : N
+pcH— Instr[31-0H- File > Memery Read Datal—s]
Address Write Addr . X ALU y
—!1 ea .
Instr[1 , Data 2 Write Data 0
1] Write Data
A
. 0
Instr[15-9] \\ @ \\
16 w 32
Instr[5-0] 9
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Main Control Unit

Instr RegDst | ALUSrc | MemReg | RegWr | MemRd | MemWr | Branch| ALUOp
R-type | 1 0 0 1 0 0 0 | 10

000000

lw 0 1 1 1 1 0 0 | 00

100011

sw X 1 0 0 1 0 | 00

101011

beq X 0 0 0 0 1 01

000100
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Control Unit Logic
2 From the truth table can design the Main Control logic

Instr[31]
Instr[30]
Instr[29]
Instr[28]
Instr[27]
Instr[26]

000, OO [ f % 2
ype " RegDst

ALUSrc
MemtoReg
RegWrite
MemRead
MemWrite
Branch
ALUOp;
ALUOp,

U
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Review: Handling Jump Operations

2 Jump operation have to

@ replace the lower 28 bits of the PC with the lower 26 bits
of the fetched instruction shifted left by 2 bits

J-Type:| op | jump target address

) ] Jump
address

26

PC By
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Adding the Jump Operation

Instr[25-0]

>/
o
o

Shift
26 |eft2

\
32
PC+4[31-28]

:

"D

Jump
ALUO Branch
MemRead
Instr Control MemioReg
Unit MemVvrite
ALUSrc
RegWrite
RegDst
10 ovf 10
. Instri25:211 (R e ad Addr 1
Instruction _ Read Address
Memory InstrEZO 16] | me e It D ata 1 zer )
i ta
Read ; a b
»PCH—> Instr[31-0] 0 File > Memory ReadDataf—»|"
Address Write Addr — poag _I\O ALU y
In str[1l 1 Data 2 Write Data
1] \Write Data
| AO
Instr[15-9] \

\ 4

»0
YAdd—>{1
—> ‘PCSFC

\16 Extend 32

Instr[5-0]

CENG3420 L06.35




EX: Main Control Unit of j

000010

Instr RegDst | ALUSrc | MemReg | RegWr | MemRd | MemWr | Branch| ALUOp | Jump
R-type | 1 0 0 1 0 0 010 O
000000

lw 0 1 1 1 1 0 O 00 | O
100011

sw X 1 0 0 1 O | 00| O
101011

beq X 0 0 0 0 1 1 01 0
000100

] 1
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Single Cycle Implementation Cycle Time

2 Unfortunately, though simple, the single cycle
approach is not used because it is very slow

2 Clock cycle must have the same length for every
Instruction

2 What is the longest path (slowest instruction)?
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EX: Instruction Critical Paths

0 Calculate cycle time assuming negligible delays (for
muxes, control unit, sign extend, PC access, shift left 2,

wires) except:
@ Instruction and Data Memory (4 ns)
e ALU and adders (2 ns)
® Register File access (reads or writes) (1 ns)

Instr. | | Mem | Reg Rd |ALU Op | D Mem | Reg Wr| Total

R- 4 1 2 1 8
type
load

store

beq

jump
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Single Cycle Disadvantages & Advantages
2 Uses the clock cycle inefficiently — the clock cycle

must be timed to accommodate the slowest instr

® especially problematic for more complex instructions like
floating point multiply

_ Cycle 1 e Cycle 2 :
Clk I I |

Iw I SwW : Waste

2 May be wasteful of area since some functional units
(e.g., adders) must be duplicated since they can
not be shared during a clock cycle

but
2 It is simple and easy to understand
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